-1

I'm trying to edit a PDF plot exported from Mathematica, using specific font Times using the plot option BaseStyle -> {FontFamily -> "Times", FontSize -> 10}, to match with the LaTeX document I'm working on. but when I open it in Inkscape or Illustrator the font for numbers is corrupt:

  • Inkscape:

enter image description here

  • Illustrator

enter image description here

I would appreciate if you could help me know what is wrong and how I can solve it?

0

The font in Mathematica is not recognized in Illustrator or Inkscape. Three possible solutions:

  1. Switch to a common font in Mathematica and export again.

  2. Install the Mathematica font on your system and the other programs should read it correctly.

  3. Type it again in Illustrator.

  • 1
    Can you select the broken fonts in illustrator and switch them to Times? Does Mathematica have the option to embed fonts on export? Do you have .PDF saving options? Can Mathematica export other file types? Maybe export the .PDF, open the PDF and copy paste the text from the PDF to Illustrator. – Webster Sep 6 '17 at 23:32
  • 1
    And Part 1: It sounds like Adobe is attempting to use its default fonts instead of the document's fonts. I was having a similar problem and the following fixed it for me (I'm using a Windows 7 Platform and Office 2010 Professional and was attempting to print a MapPoint Map to Adobe PDF in Adobe X.): – Webster Sep 6 '17 at 23:42
  • 1
    Part 2: 1. Click on START,DEVICES & PRINTERS, ADOBE PRINTER, PRINTER, PROPERTIES, PREFERENCES 2. Then under the AdobePDF Settings tab click on DEFAULT, HIGH QUALITY PRINT Next, UN-CHECK “Rely on system fonts only, donot use document fonts.” Click APPLY, OK – Webster Sep 6 '17 at 23:42
  • 1
    Part 3: 3. Go back to Step 1 andClick on the PAPER/QUALITY tab, ADVANCED Lookfor IMAGE COLOR MANAGEMENT, TRUE TYPE FONT: Clickon the “Substitute with device font.” A dropdown box will appear. Click on “DOWNLOAD AS SOFTFONT.” 4. Next, under DOCUMENT OPTIONS, click on POSTSCRIPT OPTIONS, TRUETYPE FONT DOWNLOAD OPTIONS: Click on “Automatic.” A dropdown boxwill appear. Click on “NATIVE TRUETYPE.” ClickOK to close the pop-up window. You may have to click on APPLY once youget back to the Paper/Quality tab, then click on OK to close that window. – Webster Sep 6 '17 at 23:43
  • 1
    Part 4: If Apply is available in the Adobe PDF Properties window, click it then clickOK one more time to close the window and “X” out of everything else. Yournew preferences should be saved and your document should print in Adobe just like it looks on your screen in the original program. Found Here: forums.adobe.com/thread/951202 – Webster Sep 6 '17 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.