-1

I tried to merge three layers with Blend Modes - Normal, Dissolve, Screen respectively. But the image completely differs from what it should be.

Merging layers with blend modes

How do I merge layers with various Blend Modes in Photoshop properly? If it's not possible, is there any workaround?

closed as unclear what you're asking by mayersdesign, Lucian, Billy Kerr, xenoid, Vincent Sep 12 '17 at 10:04

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Please define "properly". The fact that the result isn't what you expect is likely due to wrong expectations. – xenoid Sep 10 '17 at 8:22
  • And what did you expect it would be? Can you add another image? I can't guess that from your animation – Luciano Sep 11 '17 at 8:02
2

Try doing the same at 100% zoom. Then you should see what you expect.

The dissolve blend mode can be a little tricky. It is not anti-aliased when you zoom out. When you merge the layers the actual pixels remain the same, but the preview is anti-aliased and looks smoother.

  • +1, never heard this. If you know more so radically zoom dependent preview issues, many of us surely would like to see a list. – user287001 Sep 9 '17 at 16:45
  • I can't make a list, but it seems to happen when using 1-bit alpha. "Dissolve" blend mode and "Indexed Color" images are the only examples I can come up with. (It doesn't seem to happen with 1-bit images though, but maybe it's because the are always flat.) – Wolff Sep 9 '17 at 17:18
  • This is not just occurring for preview. Even after saving the same thing happens. How can I get the anti-aliased as output? – Clicker Sep 10 '17 at 7:00
  • @Clicker. It is not a bug. Dissolve just doesn't have anti-aliasing and looks chunky at 100%. When you zoom out (in any program) the "preview" has to introduce anti-aliasing to make a realistic downscaling. This happens with all images. It is just a very visible difference in this case. What to do to get "anti-aliased output" depends very much on what you are going to use that image for. Is it for printing (offset/digtital) or for displaying on a monitor? Do you want it to be just a subtle grain effect or do you want big chunky dots? – Wolff Sep 10 '17 at 8:45
  • It's for displaying. And yes, I'm expecting subtle grain effect (as seen before merging). – Clicker Sep 12 '17 at 3:54
0

If you merge two layers that have different blending modes, you get a normal layer that does not affect on what's under. Merge all layers at once or start from the bottom merging two lowermost layers at one time.

If you happen to have adjustment layers that have the clip option ON to limit the effect just to the next layer below, this does not work. Everything which affects only to the next layer must be merged first with that next layer.

  • Tried it, but in vain. I've attached a gif in the question, showing the issue. – Clicker Sep 9 '17 at 15:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.