0

All the other fields work as intended, except for the text setting, which seems to do nothing. Why? How to fix this?

Example of the problem.

Using GIMP 2.8.18.

  • Can you please mark in your screenshot which setting is not working. All you are showing is about "text" and I cannot see what you mean by "text setting". Maybe you have a mouse-over and can also quote the exact term which comes up in a mouse-over. In your question heading you call it "font field" (I have three of those) and below you call it "text setting". – Martin Zaske Sep 13 '17 at 15:14
2

Once you have changed anything (including the font) on some characters using the on-canvas dialog, these characters are supposed to have their own formatting and won't be impacted by the Tool options settings.

  • Is there a way around it? The font dialog in options is much better. – Chumanista Sep 11 '17 at 10:10
  • Yes, don't change the characters using the on-canvas template. – xenoid Sep 11 '17 at 10:59
  • In pango markup terms (that is what GIMP uses there), anything you select and change is wrapped into a <span /> element. The text tool options affect any text that is not inside any span. – Michael Schumacher Sep 11 '17 at 18:22
  • A possible way around this would be to change the text tools code and internal behavior and have the tool options also affect the style of a single span, provided that all text is inside of exactly one. – Michael Schumacher Sep 11 '17 at 18:25
  • @MichaelSchumacher It could be simpler to remove the <span> in that case. – xenoid Sep 11 '17 at 21:31
0

The accepted answer is correct; if you have applied formatting to any of the text by using the little on-canvas floating dialog, then the affected text will no longer respond to settings in the "Text Tool Options" or "Font" dialogs.

But there is now an easy way around it!

Select the affected text, and click the "Clear Formatting" button (as per the image below) and the text will again be responsive to the general Text Tool Options & Font dialog settings.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.