1

I have a huge document and ALL the links are broken. I have one folder with ALL the links in it, but when I relink one or two and tick 'Search for missing links in this folder', it still doesn't relink any. I really don't want to spend the next 5 hours relinking every single link. Am I doing something wrong? I copied all the links in a new folder, and tried that way - also doesn't work.

1
  • Any special character in the linked files names?
    – Vinny
    Sep 20, 2017 at 11:37

4 Answers 4

2

InDesign will normally look for links in a folder which should actually be called 'Links'. Rename this folder you have so the new name is 'Links' and make sure the source file is just outside this folder.

If this doesn't work then some files are either truly missing or have been renamed (which is something InDesign will not autodetect).

enter image description here

2
  • This is only true if the InDesign file has been packaged. Otherwise the links could point to whatever location the original images were in. The OP's "one folder with all of the links" might be called anything.
    – magerber
    Sep 20, 2017 at 15:51
  • 1
    @magerber Hence why Lucian said to rename it to Links and make sure it’s in the same folder. It doesn’t matter whether the file has been packaged or not: when a document is opened, InDesign always checks if there is a Links folder in the same folder and then looks for missing links if there is. Apr 18, 2018 at 23:09
1

Make sure that the file extension specified in the "match same filename but this extension:" dialogue box does not have a period in front of it. The image below shows the box with "jpg" typed in. This worked for me. Typing in ".jpg" with the dot, did not work for me.

Hopefully this helps someone.

enter image description here

0

I realize this is an old thread, but I'm leaving this one here in the event anyone else has this problem. I had a doc with nearly 700 links & even though I checked the 'search for missing links in this folder' option checked, it just wasn't happening. I closed the InDesign doc, placed it in the same folder as all the linked images, opened it & all links updated. I then did a 'save as' to the folder that the InDesign doc was originally in & all is well. Hope that helps somebody!

0

Also had this problem today. What did the trick for me was deleting some .indd file that was in the link folder. I received this files from other professional and didn't realized they were there.

1
  • Welcome to GD.SE!
    – Mensch
    Dec 16, 2021 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.