0

Is there a way to maintain superscript when copy/pasting from word to inDesign?

  • Not when copy-pasting, no. At least it used to be that copy-pasting from Word kept no formatting at all—you have to place the file to maintain formatting. I haven’t actually copy-pasted anything from Word into InDesign for years and years, though; this may have changed in the meantime. – Janus Bahs Jacquet Oct 1 '17 at 21:53
  • If I wasn't working from a 30+ page document, I would be doing this, but i don't think it will work unless I have each page of text as it's own file, correct? – Mel Di Pietro Oct 2 '17 at 22:08
  • 2
    Placing? No, you can place documents that are hundreds of pages long. As long as your InDesign text frames are primary and linked, and you have Smart Text Reflow enabled, you just place the document into an empty text frame and InDesign will automatically reflow the text, adding pages as required. It will import the whole document, though, not just parts of it, and it will keep styles and overrides intact unless you tell it not to. – Janus Bahs Jacquet Oct 2 '17 at 22:10
1

Here's an answer you don't want....

In my experience, maintaining styles from Word can be problematic. What if you use a document font that doesn't contain a specific setting? i.e. Word uses "italic" but you use a font that uses "oblique". Or what if the Word document is using smart quotes and you want dumb quotes, or vice versa?

For a solid, well crafted text document I always save the Word file, whatever it is, to a plain text format. Thus stripping away all Word styling. I then use File > Place to place that text document into InDesign and then go through reapplying character and/or paragraph styles as needed. I open the Word document on my left monitor for visual reference then work in InDesign on my primary monitor. In *many, many, many instances you may find that Word document had some odd "box" or callout that caused odd line breaks or issues with the import. So side-by-side comparison allows you to refine layouts as needed.

Why go to all this trouble? Well, it's not "trouble" in the grand scheme of things. By reworking the text in InDesign, you are somewhat obligated to pay closer attention to widows, orphans, page breaks, style application, special characters etc. Basically it kind of forces you to do a better job then you would if you copy/paste or slap some Word file into an InDesign document.

It doesn't take any extra time to use this method of reformatting than it does to hunt and seek for import errors and correct them. The only difference is a more confident, solid, final piece.

  • I agree. I have often wasted valuable time trying to "fix" a Word document where I should have just done as Scott describes. I wish customers would stop using Word - the texts delivered to designers should be completely cleansed for styling. The writer should only care about the content and the hierarchy of the text. My dream would be for writers to use a simple markup language like Markdown. Word documents exported from a markdown program like Typora seems to work without problems in InDesign and doesn't have all that extra trash that Word adds to its files. – Wolff Feb 1 '18 at 16:19
0

The best way to handle text import from Word to InDesign is to work up a WordBASIC macro which maps all formatting which one wishes to retain to suitable character and paragraph style and strips off all other formatting.

That way, the text imports cleanly and can be used w/o worrying about errant local formatting.

  • WordBASIC? That was replaced by VBA when Word 97 was released, twenty years ago. Did you mean VBA? Also, in my experience, no matter how hard you try to remove local formatting in a Word document, there’s still tons of it there. I always format everything as styles and never locally override anything, and still about 40% of the text has local overrides applied once I import into InDesign. Selecting the entire imported text and removing all local overrides in one fell swoop is an indispensable part of my work flow. – Janus Bahs Jacquet Oct 2 '17 at 22:15
  • The way I did this was to have a macro which tagged all the formatting, removed all the formatting, then re-applied the formatting as character and paragraph styles stripping out the tags. Sorry, started w/ WordBASIC back w/ Word 1.0 and it persisted on a Mac for rather a bit longer (through Word for Mac 2004 at least). – WillAdams Oct 3 '17 at 18:31
0

All you have to do is to make sure that Preferences > Clipboard Handling Preferences > All Information is selected, instead of Text only

  • I did this before I posted here thinking it would be the answer. Thanks tho! – Mel Di Pietro Oct 2 '17 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.