2

Long time lurker, first time poster. I've been having trouble since updating to macOS High Sierra when using Variables. I save the Excel file as a .csv but when I go to import it into Photoshop, it gives me an error saying it could not parse the contents due to a name discrepancy (see attached photo). The column name is "sku" but obviously Photoshop is reading something different. I don't understand why the strange characters are being added to the name when it looks fine in both TextEdit and Excel. Has anybody else had this issue?

screenshot

Any/all help is greatly appreciated. Thank you!

1
  • It's hard to say without seeing the CSV file, and I'm not a Mac user, but did you export the CSV using a UTF character set? On Windows, Excel has several save-as options, and the most compatible choice is "CSV (Comma delimited) (*.csv)", not "CSV UTF-8 ...". It's also possible that the line endings need to be Mac specific (no CR+LF, just CR) ... Windows also has that option; not sure what's available on Mac. If 'sku' is the first variable in your CSV, I'm guessing it's a UTF-8 issue. – Rob Craig Oct 9 '17 at 17:55
0

This is how to FIX it:

  • when importing data sets, make sure to change you change ENCODING option to match your document type
  • when it is set to Automatic, it gives me those weird characters
  • when I change it to match my document type (Unicode UTF-8), it works perfectly

enter image description here

0

It's weird, but excel saves .csv with ; instead of a , Open your csv file in a text editor and change ;s with ,s.

2
  • 1
    That’s not weird. Semicolons are perfectly standard in CSV files. Such files are not RFC 4180-compliant, but CSV is not a standardised format, and there is no requirement for CSV to comply with RFC 4180 in order to be CSV. – Janus Bahs Jacquet Feb 10 at 21:35
  • @JanusBahsJacquet Thank you for providing technical details. I don't really know much about CSV files and I just posted what worked for me, so feel free to edit my answer. – Shahriar Feb 13 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.