14

Uncheck "View -> Show -> Pixel Grid" and "surprise", no pixel grid. ;)


12

To tick off this option for a group of objects Select all the objects with the selection method of your choice (or more drastically, Ctrl+A to select all the objects in the file) With them selected, open the Transform Panel (Shift+F8). Tick off Align to pixel grid If you don't see this option, then you might need to open the extended options. To do this, ...


6

If you want to disable it in Illustrator CC2017 follow the steps below since it was changed: First click this Icon in the top right Corner: Then click the following entry in the Menu that popped up: After that, click this Button to disable Pixel Grid Snapping:


5

CMD+H hide the extras and may not be the ideal solution. Try disable the pixel grid by clicking View > Show > Pixel Grid


4

It's not "the grid" - it is anti-aliasing between shapes - anti-aliasing is showing a pixel/half-a-pixel of the blue background. If saving for web, use Art-Optimized anti-aliasing in the Save for Web dialog window. In many cases, simply adding a solid, single fill behind all the artwork will force AI to anti-alias to a correct color. In this case, I'd ...


2

Drove me crazy as well. Don't forget to untick the box for new documents in addition to the solution above. German Screenshot


2

I use Ctrl+H when I am using the patch tool. First I use the patch tool to say darken down an area that is bright by finding an area on the brighter part and patching it to a darker area. I then have marching ants on my Image My next step is Ctrl+H... I then go to Edit Fade patch selection with this you can then use the slider to blend the selection that ...


2

Could be to do with anti-aliasing as well... A workaround would be to use Pathfinder > Divide instead of a clipping mask. Will work for simple shapes like this, but if your artwork is a lot more complex it might need a more methodical pathfinder approach. Because you're left with just the shapes that make up the graphic and nothing more (ie, no background ...


2

I use illustrator and Inkscape, might I suggested you change the border to outside or outer. Based on the gif you posted you have it on centre, basically Sketch is snapping your rectangle to its anchor points, if the stroke is set to inside or outer alignment that could solve your problem. Outlining the object's stroke will help with aligning to the grid. ...


2

You can see the coordinates in the Transform panel. Changing the reference point will show you the coordinates of that reference point; this holds for area type, point type, and any other object you can select.


2

American designers are accustomed to think in terms of fractions. Now 96 is divisible by 2, 3, 4, 6, 8, 12, 16, 32... This is beneficial for pixel alignment so you dont need to round or splatter units by half pixel values. Admittedly such a system more beneficial if you need to work with dividing ghroups of humans as they resist splitting in fractional ...


2

Depending on your country settings it could be . (point) or , (comma) you have to enter. Illustrator accepts only one of the two.


1

As far as I'm aware, there are two situations when new guides made by dragging from the rulers will snap to the pixel grid: Pixel Preview is turned on (View → Pixel Preview) "Align New Objects to Pixel Grid" is checked in the Transform panel menu So, to stop your new guides snapping to the pixel grid: turn off pixel preview and uncheck "Align New Objects ...


1

I'm not sure, but since you mentioned "grid", it looks like literally "snapping" to some grid is activated. Try disabling whatever "snap to" option may be enabled in the "View" menu.


1

I can enter vallues below 1px in my Illustrator CC. You can type excly what you want. Unchek Align New Objects to Pixel Grid first. Ex: type 0,1mm or 0,5px in the preferences panel. In the picute below I typed: 0,5mm and it returned 0,05cm. That is my ruler units (cm). See the image below:


1

You have narrow pixelated lines which are mangled another time when placed into Photoshop, where the pixels probably do not fit and it's automatically resampled and antialiased. Probably quite disastrous to thin lines. Many persons make the compositions in InDesign or Illustrator and import the needed photos, because their work needs may be very different ...


1

It depends on whether your text is placed in a text frame or not. Window > Info palette will give you the coordinates of the selected element (image, text frame...) based on top left point. Window > Transform palette will also give you the coordinates of the selected element. You can set which reference point you like. See:


1

There are two kinds of text object in Illustrator; Point Type and Area Type. Point type is created by clicking with the type tool and then adding text. Area type is created by clicking and dragging with the type tool to create a box before adding type into that box. The two types of text object can be alternated between for the same object by using Type > ...


1

You have to select the object and THEN uncheck Align to Pixel Grid on the Transform panel. If the object happened to be drawn with the Pixel Grid snapping on, it'll stay on for that object until you disable it. After selecting the object and unchecking the Align to Pixel Grid, strokes should go below 1pt. And you'll also see alignments less restrictive. ...


1

I would scale the objects back up to the point where the strokes look as they should, then expand everything's appearance. This way, everything will remain consistent when resizing. Select everything CMD+A Object > Expand As for the snapping, I dunno.


1

As Scott has mentioned before me, this is the product of how Illustrator displays its anti-aliasing between shapes. If you save your art as a pixel-based image file (JPEG, for example), you should find that the lines will disappear. If you need the file as a PDF however, and you still see the lines when opening with a PDF reader, then there's only one way ...


1

The pixel grid starts showing up at a high zoom level. If the grid layout is not divided properly, it will align to subpixels.


1

It'll be difficult to find many using 1999-2000 software today. I believe Photoshop 6.0 had the Info Palette though. That shows the cursor coordinates. It'll be in the View or Window menu. This is CC's panel, 6.0's palette will look similar. The x/y are coordinates for the cursor.


1

This is just a display issue related to the anti-aliasing algorithm most programs use to display vector graphics. The effect you see is not "real", and for most practical applications it is pointless to try to get rid of it. In printing and in exporting rasters these lines don't show. To prove it, you can go into Edit > Preferences > General... in ...


1

Err.... simply choose View > Pixel Preview from the menu.


Only top voted, non community-wiki answers of a minimum length are eligible