65

For new objects, turn off "Align to Pixel Grid" on the Transform panel. For existing objects, select them first, then turn off Align to Pixel Grid using the checkbox at bottom of Transform panel.


37

There are several locations in the settings that affect snapping to a grid. View Page Grid Document Properties Snap Controls Bar Preferences We will look at each of these. The images may look different for different operating systems, but the general settings should still be the same. View Page Grid This does not directly affect snapping to the grid, but ...


20

It was driving me crazy too... you can deselect the Align to Pixel Grid checkbox on the Transform panel (shows up on "show options"), but new objects will always retain the snapping behaviour. To turn it of permanently, click on the flyout menu at the top right of the transform panel then uncheck Align new objects to pixel grid. Phew...


14

THIS HAS BEEN UPDATED IN VERSION 23.0.1 You have to turn OFF "snap to grid" behavior. The preferences for alignment of objects are in three DIFFERENT places: In VIEW menu uncheck "Snap to Point" (NOTE: this has moved in latest version to Preferences menu (see #3 below) In the TRANSFORM PALETTE un-check "Align to Pixel Grid" Other related options in ...


11

This took me forever to figure out as well. It's hardly intuitive. This bug report is what led me to the answer: https://bugs.launchpad.net/inkscape/+bug/1422296 The key is to make sure you have the right combination of 'snap to...' icons selected on the right side of the UI: To quote the above URL: - "Enable snapping", the topmost button - "Snap ...


7

In Illustrator 2019, the snap-to-pixel toggle has been moved to a more convenient location in the top right of the application. It is the magnet icon connected to three vertical squares. Clicking it toggles snap-to-pixel and the dropdown arrow to its right opens an advanced options menu with additional settings.


6

Check your Smart Guides are on. Usually when things aren't snapping the way I think they should be, it's usually because I've hit a keyboard shortcut and turned them off by mistake**. ** usually while working with type and trying to underline something... The keyboard shortcut for Smart Guides is CMD+U.


6

This is most likely caused by having snap feature enabled. Make sure you have snap to grid turned off View → Snap to Grid (Ctrl/Cmnd+Shift+")


6

The best you can do is utilize the Gradient Panel and location percentages. Illustrator does not offer any hard algorithmic method to input definitive values. Because gradients are sized based on their boundaries, everything is relative to the object and a percentage. So if you want precision you'll need to do the math and figure out what percentage of the ...


6

A desire for precision generally means the Pencil and any "drawing" Brush won't get you there. You can use the Pen Tool or shapes. The Pencil/Brush tool simply aren't designed to be precise. They are focused more on natural drawing and all the imprecision and wonder that comes with that. It's possible to start with something simple like a single ellipse .......


5

The nodes of a path will always be centered with respect to the stroke (unless when dealing with live path effects or the powerstroke, but that's a different subject) You might still be able to achieve what you want, but only when dealing with bounding boxes. For this, go to Preferences -> Tools and set the bounding box to visual (as opposed to geometric). ...


5

I would use the Pen Tool as you are working with very smooth curves here. Did you check if Smart Guides option is turned on? You can go to View -> Smart Guides or use shortcut Ctrl + U (I believe it's cmd + U on Mac). Also, make sure that Snap to Point option is selected (also in View panel).


4

These red dots are called "connection points". I don't know of any way to disable them, but you can override them by holding Alt while you draw.


4

Enable the following snapping options, and disable all the others. Enable Snapping Snap Nodes, Paths and Handles Snap to Paths Here's the result


3

Set up your grid via File → Document Properties → Grid and File → Document Properties → Snap as Suragch suggested. Or go to Inkscape preferences → Snapping and Inkscape preferences → Grid to affect all documents you edit. On my Inkscape, the grid spacing was set to 1px which is not going to be helpful, so increase it to ...


3

Here is my approach. I think the best way to snap objects is snap point in Edit mode. Let me show: Here two objects I want to snap, you can see a little gap between them: Select one object, triangle in my case, press Edit mode in toolbar menu. Now shape is in editing mode, select upper point and check position of it: Select rect and activate Edit mode....


3

As of now the snapped objects cannot be moved with the guides. You can only do it by moving your guides and then snapping the objects to the guides. (Although there was a proposal on implementation of moving objects along with the guides, but it isn't implemented yet- http://wiki.inkscape.org/wiki/index.php/SpecGuidesImprovement)


3

I am not sure if what you're asking to do is possible in Illustrator. One work around is to group the path to the object and then rotate the group.


3

I've finally found a way to do this with a plug-in called "SubScribe". It's an awesome plugin that you can download for free, by Astute Graphics. Here's the link: http://astutegraphics.com/software/subscribe/ Here's a quick tutorial: 1) Click and hold "Circle by 2 or 3 points" and select "Tanget Circle": 2) Click on a path and then click on the other path ...


3

Unfortunately Sketch doesn't snap to vector points, otherwise this would be easy. However, we can snap to the bounding box of an object and it is possible to abuse this to create a perfect star. Create a five sided polygon and remove the vector points one by one and create vertical and horizontal guidelines for each point. Then use these guidelines to snap ...


3

Make sure both these features are checked in your AI View > Snap To Point View > Smart Guides For detailed info read the official docs.


3

Well that was easy. I've been wanting this for a least a year. I found this post on github: https://gist.github.com/wrzlbrmft/53c39525cfa7a3e12f58 # ~/.gimp-*/gimprc (default-snap-to-canvas yes) That worked! I closed gimp, added above line to C:\Users\username\.gimp-2.8\gimprc file and restarted gimp Update for GIMP 2.10 In Gimp 2.10 the above doesn'...


3

@Danielillo's answer is the first and best option if it works. Unfortunately, occasionally the smart guides do not snap to the guide or object that you want. If this happens, you have a couple of options: Select the entire object, then switch to the direct select tool (white arrow). Click and hold on one of the object's anchor point, then drag the object to ...


2

Might be a late suggestions, but … You can try to misuse the "blend" option of illustrator. Make your line and apply the zigzag filter expand that line to get your guide path for the blend object make a blend object (one rectangle at the beginning of the path, one at the end, select both, choose "object" > "blend" > "make") exchange the original blend path ...


2

You can make a copy of the path, then convert the copy's border to a path by using the "Sroke to Path" command. The edge of the border has now its own node that you can snap to. Finally you can delete the copy and are left with the original path and the objects snapped to its outline. This way you can still use the geometric bounding box.


2

Sorry, no. There is no way to disable snapping without physically choosing the menu items. Good feature request though. It should be like Photoshop... Control/right-click to temporarily disable snap.


2

If you cut out the central circle from the larger circle the object path will run around the remaining "O" shape. The auto align features will then snap to this path easily.


Only top voted, non community-wiki answers of a minimum length are eligible