0

I'm working on some of my photos for the first time in a while in Photoshop CC 2018 and whenever I press Command+S on my mac or try to Save from the File menu a 'Save As...' dialog window pops up. I can't figure out what the problem is. When I first open an existing PSD document, the first save works fine but each successive save brings up the Save As window and I end up having to press Replace.

I'm not sure if it could be related to the file/folder permissions; the files are stored locally on my drive in my Documents folder and I have checked that folder and its contents have default permissions. I have tried resetting preferences for Photoshop to their defaults but that didn't change anything. I also reinstalled Photoshop and cleared my preferences in the process but nothing has solved it. Any help would be greatly appreciated.

1

Make sure your SHIFT key isn't broken on the keyboard. If it is and it keeps being pressed without your knowing this, the shortcut applied is Ctrl+Shift+S instead of Ctrl+S and you get a 'Save As' instead of 'Save'.

Another thing is if you're using some kind of cloud sync like Google Drive, Dropbox, etc, sometimes this locks files while being synced and you cannot overwrite these, and then Photoshop tries to save a copy via 'Save As'.

  • thanks for pointing that out but that's not it. I'm not getting any random capital letters in other places when I'm typing. – wakkodotyakko Aug 7 '18 at 14:13
  • 1
    @wakkodotyakko do you have a cloud sync application of any type running as Lucian suggested? Basically any program that saves a temp file before replacing the original (photoshop does/did this) may have problems with the sync program locking the file. Some programs complain about locks and die, others simply redirect to "save as". Try disabling it and see if the problem persists. – Yorik Aug 7 '18 at 14:45
  • Right. The files are all store in a folder in my Documents folder on my mac. The files aren't synced with the cloud in anyway. Unfortunately, that's not it as far as I can tell. – wakkodotyakko Aug 7 '18 at 15:08
1

I decided to check what plugins might have been creating this effect and I managed to figure it out. Consider disabling any plugins if you are experiencing this problem. In my case it was Suitcase Fusion's plug in for photoshop that was causing it. I disabled it and it worked. There was then an update for it which seemed to fix the problem for me.

  • Man that SF is slowing down everything. I eventually took it down and just managing fonts via Windows. – Lucian Aug 8 '18 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.