2

I am working on some textures for 3D .obj files in photoshop cs6 extended. The objects look pretty pixelated and low quality, but when I move the object mesh, or scene, or camera, it instantly renders 100% in the best quality.

How can I make the object look in hq all the time and not just when moving it?

I tried ctrl+shift+alt+R (and also clicked 3D > Render", and waited for about 30, 40 minutes. The object then looks better, not so much pixelated, but still pretty blurry and not even close as how it looks when I am moving it. In performance preferences I let PS uses 6GB of RAM, Drawing Mode is set to advanced, use GPU and anti alias are ticked.

Here's a screenshot, on top the object when I am not moving it, bottom when I move it:

enter image description here

  • resolution, zoom to one pixel equals one pixel. – joojaa May 21 '14 at 5:19
2

I had this same problem and did not find any other discussions addressing this issue, so I thought I'd post the solution for anyone else looking for it here. I fixed it by changing my document resolution (under Image --> Image Size). I started with a 1024x1024 document size, thinking it needed to be the same as my texture resolution. I updated it to 4096x4096 and found my object rendering much improved. The texture sizes are independent of your document size (I am new at this, so that probably should have been obvious to me to begin with).

1

It may also be that you are zooming the image. If you want the object to be bigger, just bring it closer using the tools that are specifically for 3D, which are placed over the working canvas. This happened to me. I could see the 3D model super pixellated, and it turned out I was zooming it.

0

Check your OpenGL Settings. It's likely that your static vs. moving layer is utilizing a different function entirely of your video card is being used.

  • Where can I find the OpenGL settings? And what should I look for in there? – prinomer May 22 '14 at 5:07
  • I believe what's happening is that when you are dragging the object, your OpenGL acceleration is kicking in, but when you stop dragging it you're looking at software rendering again. helpx.adobe.com/photoshop/kb/… - As a baseline, I recommend turning off all OpenGL acceleration. My guess is that when you do this, your image will now appear blocky all the time, whether or not you are dragging it. Then (sorry I couldn't find a link) dig for the problem with your smart object. – Charney Kaye May 22 '14 at 15:25
0

i got the solution .. this low resolution you see in the viewing mode is just while designing, after you did all your moves and changes click on the 3D layer and go to 3D menu then click Render or just click the shortcut ALT+SHIFT+CTRL+R. it will take a few minutes to render then you will see it with full resolution.

  • 1
    This answer doesn't seek to answer the question being asked - instead it answers a different question – Zach Saucier Mar 15 '15 at 17:12
0

@ prinomer

I've been searching for the same information. It looks like Adobe has removed the ability to change the render options while working on an object and defaults to using interactive rendering.

Read Peter Villevoye's answer over here https://forums.adobe.com/thread/1075991

https://forums.adobe.com/servlet/JiveServlet/downloadImage/2-6859248-687492/Schermafbeelding+2014-10-23+om+15.45.56.png

  • Suppose the given links are broken or down then your answer is not very usefull. Can you please add more information here, for example with which version was it removed, how was it called (suppose he asker has an older version) ... BTW: Wellcome to GD.SE! – Mensch Sep 17 '15 at 12:24
  • Hi information. As Kurt says, could you please explain a bit more what we'll find behind the link you provide and why it answers the question? That way, your answer is still of value in case the link breaks at a later time. Link rot is the main reason we really dislike link-only answers here. Thanks for your effort and keep contributing! If you have any questions, have a look at the help center. – Vincent Sep 17 '15 at 12:34
0

Although this response is much too late for those that came before me, I thought it might be useful to provide a simple solution (as most of these answers don't really answer concisely imho).... Make your containing document larger - ie. instead of using a starting document size of 1500 x 1500, try one of 6000 x 6000px. Although this makes no difference to the resolution of your textures, it does make it possible to see what you are doing whilst creating your textures.............

-4

Make the resolution around 300px either when you open a new project or open a .obj file and that's it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.