enter image description hereCan you please help me with this problem, it is driving me crazy.

When I create file in Illustrator and then export it in Photoshop it ends pixelated. How to make it crisp and sharp? Tried importing as .pdf and as .ai. Effect is the same

Thanks for answers

  • Why are you importing in to Photoshop and what size does it need to be? Photoshop works with pixels so anything you import in to Photoshop will always be pixelated (your example is zoomed to 400% too!)
    – Cai
    Dec 10, 2016 at 12:51
  • Thank you for answer. I actually need to prepare something for print, but I am not sure of size yet, so actually just wanted to have flexibility. I thought it is possible to create something in Illustrator, and it would behave similar as Rectangle Tool, or Custom Shape Tool. They can be resized and still retain sharpness. I know the end result will be raster, but hoped that I can work on it like with smart objects
    – Lowlarh
    Dec 10, 2016 at 13:55
  • have the same problem and the answers on your problem is not exactly true :/ My smart object from AI have the same issue. I thing that PS don't resize vector smart object (from AI) with "image interpolation" from preferences :( May 14, 2020 at 12:06

2 Answers 2


There are a few things you need to understand.

1) You are viewing the said layer at 400% zoom in Photoshop. This will cause the image to pixelate anyways. Since Photoshop is a raster editing program, its rendering engine works differently than Illustrator's and will show pixelation on zooming more than 100%.

2) By looking at the icon of the layer, I can tell that you have rasterized your smart object already. You cannot resize the smart object without losing quality after rasterizing it. Smart objects have an icon that icon looks like this: smart object icon

3) A problem similar to this occurs if you make a smart object in photoshop and then enlarge that beyond its original dimension. In that case, resizing will cause pixelation even if you have used vector layers. To solve that issue, open smart object and resize it according to the resolution you need it to be in original document. NOTE: This problem mostly occurs only in smart objects that were created in Photoshop.

  • OK thanks, got it....seems that I was just trying to force Photoshop to do thing it can not :-) Thank you for clear answer
    – Lowlarh
    Dec 10, 2016 at 19:33

youre zoomed in on a rasterized image. of course the pixels will show up. also check your PSD resolution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.