I'm using Illustrator CS5, MacBook Air, macOS Sierra. The eyedropper tool is only picking up a mixed black whenever I sample from a PDF or screenshot image.

Things I have tried:

  • Restarting computer,
  • Opening and closing Illustrator,
  • Updated software to latest (Sierra and latest Java),
  • Deleted Illustrator preferences,
  • Clicking the measuring tool & a whole lot of random tools to try reset it,
  • Opening Photoshop: eyedropper tool works fine there,
  • Deleted stuff to make more space on hard-drive though have plenty,
  • Ran my antivirus.

I've outlined it in more detail below for anyone confused with what is happening.

enter image description here

enter image description here

  • If all settings are ok, try "resetting" eyedropper with switching to measurement tool. Commented Jan 27, 2017 at 13:54
  • tried but didn't work :( Commented Jan 27, 2017 at 14:18
  • Whoops forgot to put a list of things i have tried: restarting computer, opening and closing illustrator software, updated software to latest (sierra and latest java), deleted the preferences thing, try to click the measuring tool thing & a whole lot of random tool to try reset it, opening photoshop: eyedropper tool works fine there??, deleted stuff to make more space on hard-drive though have plenty, ran my antivirus. The above options didn't work :( Commented Jan 27, 2017 at 14:32
  • In photoshop the answer would be easy. You are in quickmask. But illustrator should not act that way. what color space are you working in? And how eyedropper work in totally new file with objects created in il? Commented Jan 27, 2017 at 14:44
  • I'm afraid you may need to upgrade from CS5 if you want to use Apple's cutting edge operating systems. CS5 is quite old at this point and Apple has changed a great deal "under the hood" of the OS.
    – Scott
    Commented Mar 20, 2017 at 19:21

3 Answers 3


Have you checked the eye dropper tool options by clicking twice on the tool's icon? See if the appearance option is enabled and if anything changes by changing the settings

  • tried already :( , appearance unchecked, checking them makes the eyedropper tool not pick up colour (but weirdly enough picks up the artboard white as black)?? Commented Jan 27, 2017 at 14:20
  • Did you check in the Color Panel if the color mode is not Grayscale? Commented Jan 27, 2017 at 15:21

Use a Png file. It seems to work. My professor was having this problem in class for his demos, and I found this tread. So when I read him how others had tried troubleshooting it, he came up with the idea of tiring another file type for his image.

  • what do you mean by that? Use the PNG how? Please expand your answer to explain how to do it.
    – Luciano
    Commented Mar 31, 2017 at 9:28

I had this same problem. In appearance, I had done a second fill color on an object, and then I had left that second color as "selected", in my case it was a grey color. I had to go back and "select" the first fill color, which was orange, and then the dropper was able to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.