2

I'm using a forced line break (a.k.a. soft return) in my chapter titles. I'm grabbing those paragraph styles to generate a table of contents. But now the text for those chapter titles can get broken up in my table of contents at the end of a page, as shown:

enter image description here

How can I prevent this behavior? My workaround is to add a page break in front of the Chapter 14 line so that it begins on the following page. But I'd rather modify the paragraph style that I'm using in my TOC so that I don't have to go through and manually add page breaks every time I update the TOC.

I tried setting the Keep options for that paragraph style, but it had no effect.

1

Luke’s answer is correct that the Keep Options are the place to look. In addition to what Luke says about setting the Keep Lines Together option for the paragraph you’re having trouble with, however, there is another side to it: the Keep with Previous and Keep with Next options found right above it.

If you tick the Keep with Previous option, InDesign will avoid column/frame breaks between this paragraph and the one before it.

Similarly, if you set the Keep with Next option to any number higher than zero, InDesign will avoid column/frame break between this paragraph and the following X lines (where X = the number you specify in the field).

A problem can then arise if you have several paragraphs of text, enough to fill more than an entire column/frame/page, and all of them have the Keep with Previous and/or Keep with Next options set as well as having the Keep Lines Together option set to All Lines in Paragraph.

If this happens, you will—quite logically—end up with a text container, an amount of text that won’t fit into the container—and an InDesign which is told that it’s not allowed to add a break to the next container anywhere at all in the text.

So what is InDesign to do? Well, there are two options, and I think both have actually been chosen at different points in the history of InDesign:

  • Ignore the user’s settings, since the user is clearly wrong here, and just break the text where the container ends
  • Honour the user’s settings and suffer the consequence that the text won’t fit in the container—in other words, throw up your hands, throw an error, and make all the text overset with an empty container
2

Keep Options is the right direction here. If your style is not being overridden by direct changes, or other styles, then the options here should have it covered.
Keeping all lines of the paragraph seems the right option for your purpose. enter image description here

  • Ah @Luke, you beat me to the punch by just a few minutes! :-) – magerber Jun 14 '17 at 23:04
  • I am applying Keep Lines Together to this style, but the text is split anyway. Maybe it's related to how the text is being generated by the table of contents, rather than being typed in manually. – peacetype Jun 15 '17 at 0:03
  • 1
    @peacetype If that happens, it's usually because all the preceding and following paragraphs also have Keep All Lines Together, and all the paragraph styles are also set to Keep With Previous/Next. When that happens, InDesign ends up with no possible place to break the page, so it ignores the Keep options. Keep options are normally honoured in generated ToC text. – Janus Bahs Jacquet Jun 15 '17 at 19:15
  • @JanusBahsJacquet Awesome! That appears to be what was causing the problem. When I tried toggling those Keep options on the surrounding paragraph styles, the problematic content started moving around the page. I think I can re-configure my paragraph styles now so that the chapter headings don't get broken up. If you want to put this solution in an answer I'll accept it as the answer to this question. Thanks! – peacetype Jun 15 '17 at 21:14
2

Which of the "Keep Options" did you use? It seems to me that it should work if you used the keep all lines in the paragraph option in your TOC style definition.

enter image description here

I apologize if you have already tried this and it didn't work. I wanted to post this as a comment/question, but then decided it would benefit from a picture, so I am posting it as an answer.

A good article that talks about how the different "Keep" options interact with each other (you might find it useful) is this article at InDesign Secrets.

  • Thanks, I replied in comment to Luke's answer. I tried all the different Keep options for good measure but they do not work to keep those lines from splitting. I even tried enabling Keep on the chapter paragraph style which the TOC is using to generate the problematic text. No effect. – peacetype Jun 15 '17 at 0:05
  • 1
    You would need the Keep function in your TOC paragraph style for this to work, but if, as you say, it is still not working, then I think it probably has something to do with your use of the soft line break. You might want to also post on the InDesign Secrets website forums--there are some real InDesign wizards there who might not hang around here. – magerber Jun 15 '17 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.