7

In my Inkscape file, i have some pictures. Some of them are cropped, others are downsized/small relative to the paper size.

But when I export a PDF, the images are included in original resolution with the whole image (in the background) despite the cut offs (crop / clipping)! This makes for extreme file sizes!

How can I reduce the images' resolution when a PDF is exported in Inkscape? And is there anyway to tell Inkscape not to include cut offs in the background?

1 Answer 1

7

Replace the problematic clipped or scaled images with bitmap copies (Edit > Make a Bitmap Copy) before making the PDF.

The original clipped or scaled versions can stay in their places with no harm if you hide them in the Objects panel. Hidden objects stay out of the PDF.

Renaming or keeping the bitmap copies in another layer is essential to retain order.

Do not lose the original version, you can need it later because extra steps are a possibility for errors.

Be sure your Create Bitmap resolution is set high enough in preferences:

enter image description here

1
  • 1
    This works well, the only issue being that you need to do it for every single image, manually. It's a shame there is no way to export PDFs and have all images automatically converted.
    – typeable
    Sep 28, 2023 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.