0

I'm trying to automate assets generation with batch file processing and few actions applied to each file. Everything is fine, except I need to run "Extract Assets" command from new 14.1 CC and when I do so in "Record action" mode – nothing happens. Extract Assets (unlike Safe For Web, that work fine!) just ignored.

Any way to add this tool into action manually?

  • What is it that you're trying to do with the action? Maybe there's a way to get around it. – Joonas Oct 21 '14 at 21:52
  • Assets Localization. I have over 30 images for each of 24 languages. For each PSD some text from Data Set should be applied, some smart filters should be rendered, and in the end I'd like to have all assets saved for Web. Safe for Web tool doing the job, but it has 8192x8192px limit, and works really slow, so, I'm thinking about new "Generate Assets" tools. There are few workarounds exist indeed, I described one bellow, but I have expected some one know way to add "Generate assets" tool directly to PS Action. – Maksim Okala-Kulak Oct 22 '14 at 13:36
  • I'd have to try this to get a better grasp of the issue. I was thinking that at the very least, scripting would solve issue. However, did I understand correctly, that renaming the layers was the bottle neck of your newfound method? If so, maybe this answer could help – Joonas Oct 22 '14 at 19:18
1

Oh this is weird. I will check in with the team and find out why this is the case (I work on Extract Assets at Adobe).

Update ah so the technology stack we use under the hood for Extract Assets does not support this. I will investigate to see what we need to do so. Thanks!

  • Thank you for answer! I have found a work-around: layers can be renamed to something like "Map_Patch_12.png" with Actions (it just takes time to manually add all 24 layers to action), and all files with such file names will be extracted if "Generate Assets" checkbox checked. But it will be nice to have Extract Assets with default behaviour available for PS Actions one day! Good luck ) – Maksim Okala-Kulak Oct 21 '14 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.