I created some art with a Rectangular grid tool. I created the shape, converted to a live paint and started my pixel art.

As I was done I tried to save it to SVG but when you open the image, it shows sort of transparent lines through the image. The file has to be a SVG file so can't compromise to a PNG.

My question is: How can I save a AI file (grid + live paint) to SVG without getting transparent lines through the image?

  • a screen capture would help.
    – hsawires
    Commented Jan 8, 2015 at 21:09

1 Answer 1


This is just a display issue related to the anti-aliasing algorithm most programs use to display vector graphics. The effect you see is not "real", and for most practical applications it is pointless to try to get rid of it. In printing and in exporting rasters these lines don't show.

To prove it, you can go into Edit > Preferences > General... in illustrator (Ctrl + K), and untick the "Anti-aliased Artwork" checkbox. The white lines will disappear. Other programs have similar options to turn off anti-aliasing. You just have to find them.

The downside to turning off anti-aliasing is that curved paths will now look less smooth. Some people might prefer this since it is less noticeable and certainly more logical than the white lines. Keep in mind that this is all still only display settings, and if you open the files in another program that has anti-aliasing on, the smooth curves and white lines will come back.

If you permanently want to lose sight of those lines you can use one of the many workarounds such as adding very thin strokes, offsetting the shapes to a very small distance, or making a copy below your artwork and scaling the group a little...

Use whatever solution works best for your needs.

  • It was a graphic for a game. The transparent lines made it look like the picture was transparent cause you could see the background through the image. So basically I just have to draw thin strokes on the places where its transparent or one of the other options that you have suggested. Thanks for the answer!
    – Freyr
    Commented Jan 8, 2015 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.