2

When I copy a path-object from Illustrator (I use CC 3.0.8.310) to InDesign, the bounding box of the object is totally screwed up in InDesign. It's always much bigger than the original object, but in Illustrator it's fine. I checked that there are no other objects accidentally copied along with the original one, so that's not the issue. In some cases, selecting the paths with direct select and cut -> paste them in InDesign will solve it, sometimes it does not.

I've never encountered this problem in older Versions nor on other systems.

I hope this question is not a duplicate. I searched for it here and on Google, but it may be due to my poor English that I didn't find a solution to this.

5 Answers 5

1

1) Start new 'pasting' layer in ID.

2) Paste objects.

3) Direct select bits you want and cut.

4) Delete pasting layer.

5) Paste the direct selected bits where you actually want them.

1
  • nice answer! i think yours is more convenient than the accepted one
    – maxE
    Mar 12, 2023 at 14:41
0

Yeah, that annoys me too sometimes -_- Anyway, whenever you copy Illustrator vector then paste into InDesign, it's always grouped right?

So, after you paste into InDesign:

  1. ungroup the stuff (Ctrl+Shift+G or Cmd+Shift+G)
  2. Shift-select the parts you need (this will DESELECT them)
  3. then DELETE with all your might!! ! (it will delete the still selected invisible objects) :')

If while ungrouping you get an error saying "This value would cause one or more objects to leave the pasteboard":

  1. move around the group so that it's within the pasteboard
  2. and THEN you can ungroup them
  3. deselect the stuff you need
  4. then delete the invisible trash :')

I hope my explanation is okay. If you need further help, pls. just message :')

Cheers.

2
  • Thanks. This is a nice solution. The "Bug" itself is still very annoying. Hope Adobe will fix this, since it did not occur in older versions as far as i know. Cheers and thank you
    – pute
    Oct 17, 2016 at 20:30
  • Great, you're welcome! I'm glad I could help :') Oct 18, 2016 at 12:10
0

Normally your would place AI artwork in Indesign as a link, instead of copy pasting. That being said yes there are some situations where you will get a bounding box when pasting, but again most professionals would advise against pasting anything from AI to ID. Use links instead.

1
  • but i gotta say i strongly disagree with that view. ID has path-functions itself and working with paths in ID is pretty standard i'd say. Adobe wouldn't have implemented the option of copying paths with all the editing options if it wasn't a viable option.
    – pute
    Oct 16, 2016 at 13:31
0

I agree. It should work between the two, no question. This is an old old post, but just saw the same issue happening. It fixed for me, in indd2021 by putting the object I was copying straight on a new artboard, and bingoringo, worked a treat! Hope that helps!

0

First, save the Illustrator file as an SVG file. Then open the SVG in Illustrator, then cut and paste into InDesign.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.