0

enter image description here I am trying to move this selection for use elsewhere, but dragging, copying, and cutting all produce this same strange result of leaving pixels behind. You can see parts that are definitely within the selection not moving with the rest. I know the edges are not very clean, but that doesn't matter too much to me. I added a contrasting background so you can see the affected areas better. How can I resolve this?

I do have other layers, but none of them are anywhere near this part of the image.

enter image description here

  • How are you creating the selection? Also, as a trouble shooting exercise, have you tried making a standard rectangular marquee selection of the same area to see what happens? – Westside Nov 1 '16 at 12:24
  • I was using a combination of the lasso and magic wand tool. I did just use the rectangular selection and it came off clean... So I guess my question would be how can I prevent the magic wand (since it's most likely the culprit) from leaving those pixels behind? – Samantha Crow Nov 1 '16 at 21:59
0

Based on the above comments, there are a couple of options:

You could make the selection in a different way. You could use just the lasso tool to make your selection so that you know the edges are clean. For accuracy and control, you can hold down the alt/option key while you draw the selection. Another option is to use the path tool to draw a path around the area that you want to cut and then turn that path into a selection.

Alternatively, you can use the magic wand (or whatever) to make a selection as you have been doing and then save that selection to a channel. You can then view and edit that channel to tidy up any rough edges or holes before using the channel to make a new, clean selection.

The best option will depend on your personal preference and the way that you work, but I would suggest using paths. They are precise and easy to change and they add almost nothing to the file size. You can also save several different paths for different selected areas.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.