2

I select the rotate tool and click a layer that contains an image. I see a selection around the image. Not sure why and how to remove it. I rotate the layer. The rotated image is clipped against the selection, which means the rotated corners are cut off.

How do I rotate a layer without having it clipped against the selection?

I've tried all the different 'clipping' values in the tools menu. They all end up cropping the rotated image.

3

Do this:

Use the rotate tool. The canvas clips the image. But the image is now bigger than the canvas - the yellow dotted line shows the layer boundary.

Click Image > Fit Canvas to Layers, and the canvas expands to fit the rotated layer.

enter image description here

2

What you need is Clipping: adjust. However this resizes the layer but not the canvas, so if you start with a layer which is as big as the canvas, you may also need to use Image>Fit canvas to layers.

Unlike the paint tools, the Transform tools do not behave the same with a full selection or with no selection. To remove the selection, use Select>None.

0

I know this is an old post but I ran into this issue as well and for me doing a Select->None allowed the layer to rotate without clipping. Gimp looks to have auto-resized the layer with nothing selected.

  • For me (GIMP version 2.8.2), said "Select->None" option is greyed out... – Digger Jun 6 '18 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.