I'm trying to join these separate paths so that the black outline is seamless. For some reason the open endpoints between two points won't join with the Join command. I have tried the Divide tool on Pathfinder, as well as the Paint Bucket Tool, but cannot get the effect I am wanting.

]

enter image description here

This warning indicates either one path is inside a group and the other path is not in a group.

Or both paths are in different and separate groups.

Or at least one path is a text path or graph path.

In order to join anchors of separate paths, both paths need to...

  • not be in any groups
  • both paths must be in the same group if grouped
  • not be a text path
  • not be a path within a graph (chart)

Isolate the strokes on a separate layer from the grey fills, turn on smart guides so you get snapping, and make dead sure that the knots / nodes are actually directly aligned / coincident - try joining again.

When / if the join fails, note what the fail dialogue gives as the reason: it may be as simple as these two items being in separate groups, which is easy to fix.

  • I added a picture of the notification I get, as well as a picture of two endpoints selected. I don't know what directly aligned/ coincident means, could you clarify? Smart guides is turned on. I tried isolating the paths onto a new layer but it did not change anything. – Ryan May 15 at 17:54
  • @Ryan - join works if you align two knots DIRECTLY over one another - so you snap one point onto the other, select BOTH knots with the direct select tool (white arrow) then invoke Join. It does not create path element between two unconnected points. – GerardFalla May 15 at 17:57
  • This isn't working either. Is there anything else you know of that I could try? – Ryan May 15 at 17:59
  • Sure looks like you have them each in separate groups from the dialogue - ungroup everything and try again mate! – GerardFalla May 15 at 18:02
  • 1
    I had them in a compound path. Once I released this it worked. Thanks! – Ryan May 15 at 18:05

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.