2

I'm new here so I will do my best to cover all the details. To start I'm using two programs, Blender and Gimp. I used Gimp to set up the original images need to build a 3d coin in Blender, used Blender to build and render a 180 rotation of said coin, and went back to Gimp to export it as a gif. Everything has been smooth until I looked at the finished gif.

Text

As you can see, it's exporting with white pixels all over it. What it should be looking like is this.

Text

Once I got the frames from Blender on to Gimp, the only thing I did was use the Optimize for gifs filter on Gimp and the playback didn't show any of the white pixels. What can I do to fix this?

10
  • Hi. Welcome to GDSE. It's almost impossible to tell what has gone wrong here from the images you've shared. You've linked to a video, not a GIF. What was the original format? How did you get the frames into GIMP? What are your GIF export settings? – Billy Kerr May 18 at 20:34
  • Those areas are not white... they are transparent. You can see here that they adjust to the background color. I'm not a Blender or Gimp user, but my guess would be you've got white set to be transparent somewhere, as opposed to merely a transparent background. (I'm not sure what "video link" @BillyKerr is referring to) – Scott May 18 at 21:01
  • @Scott if that's so, then it might be something to do with original image format. If the original frames are in Indexed colour, that could easily mess everything up. – Billy Kerr May 18 at 21:06
  • heh.. note the "here" link above.. will open on a black background in Chrome, making the transparency clearly visible when compared to the image here (on a white background). I just realized that some browsers may open the stand alone image also on a white background. Making my link seem pointless -- but it's not :) – Scott May 18 at 21:11
  • @Scott - yeah I can see it now, wasn't working before for me. But is now. You're right, there's transparent pixels inside the coin. I can see it in Firefox with the Transparent Standalone Images plugin. – Billy Kerr May 18 at 21:14
2

So for anyone following behind me, I found the solution that worked for me. The original format of the frames prior to trying to export as a GIF out of Gimp were PNGs that were placed in a tmp folder by Blender with the following setting as the output.

Blender Output Settings

I then used the Optimize (for GIf) filter that Gimp offers and exported as a Gif with the following settings.

enter image description here

What I ended up discovering is that if I skipped the Optimization (for Gifs) filter on Gimp, I got the correct and smooth looking Gif I was after. You can see what I mean at the following link. pretty not messed up gif

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.