0

Using Inkscape v1.0.2-2, I now experience a problem with strokes for any shape tool. I try to make a rectangle with a black stroke color, a .3 thickness, and no fill color. It was working and then changed when I went back to the file. The problem stays no matter what document I open, even after closing/restarting Inkscape or restarting Windows. I search far and wide but cannot find a solution that works for my particular situation.

Things I've tried:

  • Checking the "fill and stroke" options for 100% opacity and Alpha values.
  • Checking the "Layer" options for 100% opacity and Alpha values.
  • Checking the "Objects" option for 100% opacity and Alpha values.
  • Redrawing a new rectangle with solid stroke and no fill.
  • Changing the "Document Properties" settings for color profile.

Does anyone have any clues as to why I cannot draw a simple, solid-colored stroke?

Here's the link to the sample file: https://tinyurl.com/4kwy69nm

2
  • Hi. Please share a screenshot showing what is wrong. The SVG looks fine to me.
    – Billy Kerr
    Nov 6, 2023 at 19:27
  • When I save a screenshot, new strokes appear correctly like the original strokes—just not in Inkscape. In Inkscape, it alters between thicker/50% transparency (gray) and thin/solid black when changing the zoom. The screenshot renders it all the same, too, but it looks like one or the other when zooming in/out. This has happened once before, and I don't know the cause. It's hard to draw if it doesn't portray accuracy. Perhaps it's a GPU rendering issue or something.
    – salmmus
    Nov 7, 2023 at 19:48

1 Answer 1

0

There is nothing wrong with the file you've provided and it displays correctly for me. Inspecting it inside a text-editor doesn't show anything that could cause the behavior you're describing either.

It sounds like you may be in 'Outline Overlay' display mode, even though that didn't exist yet in version 1.0.2.

Switch back to normal view with 'View → Display Mode → Normal'.

From your comment on the question, it sounds like it could actually be just anti-aliasing. If lines don't quite align with the pixel grid of your screen, they have to be spread across two pixels making it look thicker and a little faded. It's a technical limitation of how graphics are displayed on screens.

Example of anti-aliasing on magnified pixel grid

You can either disable anti-aliasing, which will create jagged-edges especially on diagonal lines, however, or try to align objects with the pixel grid by nudging them a little or switching to 'px' units and snapping.

4
  • Already tried to change display mode. It was already on Normal, but I changed it and then changed it back. As for the version, maybe I'm looking at it wrong.
    – salmmus
    Nov 7, 2023 at 3:38
  • Here's the "About" info. mediafire.com/view/fxi9xs1o6813qla/Inkscape-About_Screen.png/…
    – salmmus
    Nov 7, 2023 at 19:11
  • @salmmus - that's an old version of Inkscape. Get the most recent which is version 1.3 at inkscape.org
    – Billy Kerr
    Nov 7, 2023 at 20:19
  • @salmmus Weird, the official download page doesn't have such a version. Anyways, as BillyKerr says, upgrade first and see if that fixes things. Also, from your other comment on the question post, since it's zoom dependent, it may just be anti-aliasing. Maybe because the line doesn't quite align with the pixel grid of your screen, it has to be spread across two pixels making it look thicker and a little faded.
    – Xrott
    Nov 7, 2023 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.