I am an Architecture student creating some graphics for my website. I am trying to set up some construction lines for my graphics and the snap to points tool is not setting my anchor points to the right location.

I've tried turning off the snapping and align options in both the the view drop-down and transform fly-out menus. After which I manually assigned my anchor point locations but it just reassigns to locations that don't line up.

I select an anchor and change the X,Y to 1000,500 and then select the anchor point that is supposed to be vertically aligned with the previous one, set it to 1000,500 as well and Illustrator sets one of the two points to 1000.5, 499.5.

2 Answers 2


This is most likely caused by the type of stroke you have on the object. An object's stroke can be rendered in three ways:

  • Align Stroke to Inside which places the stroke inside the edge of object.

  • Align Stroke to Outside which places the stroke outside the edge of object.

  • Align Stroke to Centre which places the stroke centred on the objects edge: half of the stroke will be outside the object, half of the stroke will be on the inside of the object.

I suspect your object has a 1px stroke, set to Align Stroke to Centre. The means that if you place your anchor at 10,10 - the position actually be 9.5,9.5 as half the 1px stroke 'leaks' outside your object edge.

Try changing the object to Align Stroke to Inside (or remove the stroke entirely) by using the Stroke panel accessible from the top toolbar.

Screenshot of the Stroke panel


You need to open the transform panel (window -> transform).

Then, disable the "keep proportion" option (the icon looks like the link of a chain).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.