1

Here is what's going on: The graphic on the left does not have a fill, while the graphic on the right does have a fill.

Here's what I am trying to do: My end result is that I would like the graphic that doesn't have the fill to closely resemble the graphic on the right, even without a fill covering up the extra lines. To get the graphic on the left to look how I would like, I would need to remove the parts of the shape that have a red line over them.

When I use Pathfinder to try and remove the unwanted lines, it produces a result that ends up removing far too much.

Does anyone have an idea of how to accomplish this removal cleanly and/or without Pathfinder?

Edit: I should also mention that these graphics are made up of 4 individual rounded rectangles that are not merged / united together.

5

Pathfinder doesn't work on strokes well, if at all. You're essentially trying to remove live strokes and Pathfinder isn't really good for that. You would need to expand the strokes for Pathfinder to work effectively.

You'll have better luck using the Shape Builder Tool. Just select the art and click-drag on the areas you want to combine.

(4 stroked, unfilled, rounded shapes)

enter image description here

I'm merely hitting Undo a few times in between iterations.

  • How do you make the animation? – Webster Nov 16 '17 at 19:37
  • @Scott After looking at the graphic more closely (after using the Shape Builder tool) it added many anchor points to parts of the vectors, which slightly distorts the art (it's minor, but noticeable when zoomed in). Do you know how I can stop that from happening? I've been reading other forums, and they say to uncheck "Align to Pixel Grid", and I did do that, but the problem persisted. – Matt Nov 21 '17 at 18:37
  • @Scott Apologies — I think I figured out what I was doing wrong. – Matt Nov 21 '17 at 18:42
0

Pathfinder has 8 tools in it. For this task I recommend you use Divide:

First Expand and Ungroup the shapes. Make sure they have the same fill and stroke.

Select all and hit Pathfinder>Divide.

Ungroup them.

Delete the unwanted parts.

  • Ah. I didn't use Expand first, which is why it didn't work. Thanks for the solution! One more quick question. When I used Divide, it created very very thin white lines where each shape intersects. (imgur.com/a/tUwys) Is that normal? – Matt Nov 16 '17 at 19:14
  • Yes, I think those dotted lines are only indicators that the shapes are divided there and are not visible when you export the image. However, I failed to tell you how to use pathfinder to put everything back together. Select all the blue shapes that you want to be joined and use Pathfinder>Unite. – Webster Nov 16 '17 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.