I am currently doing a table of contents in InDesign and have run into yet another problem, namely the spacing:

table of contents with incorrect spacing

My TOC features two levels of headings. To make the top-level heading stick out more, I decided to give it some more room by increasing the "space after". This however results in the lower-level headings to really stick to the next top-level heading after them.

Now I did figure out, that I can simply increase "space before" for the top-level heading, however that leads to the very first of them to also shift down.

screencap showing which line moves down unwantedly

Is there a way to make the very first one an exception? Normally I would just define two paragraph styles: One for the very first element and one for all the other ones (or rather tackeling the whole problem from the other side by increasing "space after" for the very last lower level heading), however with a TOC I can only define one paragraph style per heading-type (at least from what I know) and therefore this is not an option.

While I could edit that manually, this is something that might be easily overlooked when the TOC will be updated in the future, so if possible I would like to make this somewhat "automatically".

1 Answer 1


Two suggestions :

  • decrease the "space after" value of your "Table of Contents" Title paragraph style
  • place "Table of Contents" title and the Toc content in two separate frames. You can thread them. If you choose not to thread them, remove the title in the TOC panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.